API inconsistencies

Nick Kew niq at apache.org
Mon Nov 25 17:49:18 UTC 2013

On 25 Nov 2013, at 16:46, Ruslan Ermilov wrote:

> nginx_version in src/core/nginx.h.

Thanks.  Seems to be 1.5.3 at the time of that commit, so I guess
the test I need is < 1005003 vs >= 1005003?

But that presumably only works with release versions, so anyone
compiling against arbitrary versions will have to deal with it
case-by-case (in this instance, either API could apply to
version 1005003)?

Nick Kew

More information about the nginx-devel mailing list