<span class="Apple-style-span" style="font-family: Arial; font-size: medium; ">Thanks for the comments.<br style="clear: both; ">I have several questions:<br style="clear: both; "><br style="clear: both; ">1. You mentioned "style problems". What exactly are they? The web page of<br style="clear: both; ">
mail list will trim the spaces/tabs so it's hard to judge the problem. Last<br style="clear: both; ">time, you commented my code that there should be no space between the<br style="clear: both; ">function name and "(", that's clear. I want the suggestions like that.<br style="clear: both; ">
<br style="clear: both; "><br style="clear: both; ">2. You mentioned "It's not clear why you are trying to do two different<br style="clear: both; ">"resolve" in a raw, each of them calling gethostbyname/getaddrinfo. Looks<br style="clear: both; ">
silly." Do you mean I use "getaddrinfo/gethostname" in<br style="clear: both; ">"ngx_inet_parse_hostname" and "ngx_inet_resolve_host" respectively? The old<br style="clear: both; ">code use twice "gethostbyname" too. So I follow the way. What's your<br style="clear: both; ">
expectation? Please make that clear?<br style="clear: both; "><br style="clear: both; "><br style="clear: both; ">3. You mentioned "This change is completely unrelated and not really needed.<br style="clear: both; ">
You may want to avoid cluttering patch with such changes." Do u mean I<br style="clear: both; ">shouldn't convert the code to the new function "ngx_inet_resolve_host_name",<br style="clear: both; ">or shouldn't I move up the "sin->sin_port" set code.<br style="clear: both; ">
<br style="clear: both; "><br style="clear: both; ">4. I admit this diff is hard to review, especially in the function<br style="clear: both; ">"ngx_inet_resolve_host". The old code structure is completely changed and<br style="clear: both; ">
rewritten because a) the interface of getaddrinfo and gethostbyname is<br style="clear: both; ">different; 2) I try to avoid too much duplicated code brought by directly<br style="clear: both; ">expending the old code. So I strongly suggest you should review the merge<br style="clear: both; ">
result of "ngx_inet_resolve_host". It's not feasible that you can always<br style="clear: both; ">tell the mechanism of the fix from diff. Of course, I'll try my best to<br style="clear: both; ">shrink and split the diff into little ones.<br style="clear: both; ">
<br style="clear: both; ">I can imagine how busy you are. But I'm a new guys to do the nginx dev so<br style="clear: both; ">please give more advices like "what is good" and "what should be done". This<br style="clear: both; ">
would save time to both of us.<br style="clear: both; "><br style="clear: both; ">Thanks.</span><br><br>