nginx+memcached produces odd Quotation mark!!!!

zhan superxain at
Wed Jul 30 16:58:28 MSD 2008

When I tried to use nginx and memcached  module, 
the output always had a odd quotation mark 
before the cached content.

I have tried nginx/0.6.32 and nginx 0.5.34
I used:
ruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux] and
ruby 1.8.7 (2008-06-20 patchlevel 22) [i686-darwin9]
memcached 1.2.5
libmemcached 0.22
memcached gem 0.11
memcached-client 1.5.0

here is my nginx conf file:
worker_processes  1;
pid        /www/logs/;
events {
    worker_connections  1024;
http { 
    server {
        listen       80;
        server_name  localhost;
        location / {
          default_type text/html;
          set $memcached_key $uri;
          memcached_pass localhost:11211;

after I setup a cache:
irb(main):002:0> require 'memcached'
=> true
irb(main):003:0> c ='localhost:11211')
irb(main):006:0> c.set '/test', 'hello'

when I opened with safari 3.0 or 
Firefox 3, I didn't get 

I get no idea where the Quotation mark coming from!!!!! 
Can anyone tell me how to fix it?

More information about the nginx mailing list