Problems with fastcgi php migration

Ian M. Evans ianevans at
Thu Mar 13 00:47:07 MSK 2008

Igor Sysoev wrote:
> This is my mistype, it should be:
>   set  $script_name  $1;
>   set  $path_info    $2;
Unfortunately that caused a 404 in each of the three test cases. Bizarre.

You did want me to set cgi.fix-pathinfo in php.ini to 0 (off) right?

Here's the whole location with the fastcgi_params in case we're missing 

location ~ ^/(testgalleries|galleries|poll|news)(/|$) {
root /usr/local/apache/htdocs;
set  $script_name  $uri;
set  $path_info    "";

if ($uri ~ ^(/[^/]+)(/.*)) {
set  $script_name  $1;
set  $path_info    $2;

fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
fastcgi_param  SERVER_SOFTWARE    nginx;
fastcgi_param  QUERY_STRING       $query_string;
fastcgi_param  REQUEST_METHOD     $request_method;
fastcgi_param  CONTENT_TYPE       $content_type;
fastcgi_param  CONTENT_LENGTH     $content_length;
fastcgi_param  PATH_TRANSLATED    $document_root$fastcgi_script_name;
fastcgi_param  REQUEST_URI        $request_uri;
fastcgi_param  DOCUMENT_URI       $document_uri;
fastcgi_param  DOCUMENT_ROOT      $document_root;
fastcgi_param  SERVER_PROTOCOL    $server_protocol;
fastcgi_param  REMOTE_ADDR        $remote_addr;
fastcgi_param  REMOTE_PORT        $remote_port;
fastcgi_param  SERVER_ADDR        $server_addr;
fastcgi_param  SERVER_PORT        $server_port;
fastcgi_param  SERVER_NAME        $server_name;
fastcgi_param  SCRIPT_FILENAME  $document_root$script_name;
fastcgi_param  PATH_INFO        $path_info;
fastcgi_param  REDIRECT_STATUS    200;

Odd how it goes from incorrect path_info to 404's.


More information about the nginx mailing list