Multiple ssl certs for the same IP?

Ed W lists at
Thu May 29 21:23:52 MSD 2008

> This extension is called SNI. It supported by IE7, but only under Vista,
> and I'm not sure will MS add these crypto DLLs in XP. Also SNI is supported
> by Opera8 and Firefox2. To support SNI from nginx side OpenSSL-0.9.9
> is required, that is currently in developing stage.

It appears that SNI support has been backported to at least OpenSSL 
0.9.8g ?  You need to specify --enable-tlsext when building openssl

What else is required on the nginx side in order to test TLS upgrades?  
Does someone have a sample config showing this working on some web browser?


Ed W

More information about the nginx mailing list