Problems building nginx-0.6.35 with fancyindex_module 0.1b5

Robert Gabriel lists at
Tue Jan 27 10:41:56 MSK 2009

Im trying to upgrade my nginx from 0.6.34 to 0.6.35 and was using an
add-on module called nginx-fancyindex_module 0.1-beta5. Seems that with
this version of nginx the modules doesnt work at all:

gcc -c -O -pipe  -O -W -Wall -Wpointer-arith -Wno-unused-parameter
-Wno-unused-function -Wunused-variable -Wunused-value -Werror -g   -I
src/core -I src/event -I src/event/modules -I src/os/unix -I objs -I
src/http -I src/http/modules -I src/http/modules/perl -I src/mail \
objs/addon/nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.o \
cc1: warnings being treated as errors
../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c: In function
../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c:429: warning:
implicit declaration of function ‘ngx_utf_length’
../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c:430: warning:
signed and unsigned type in conditional expression
../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c:571: warning:
implicit declaration of function ‘ngx_utf_cpystrn’
../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c:571: warning:
assignment makes pointer from integer without a cast
make[1]: ***
Error 1

Does anyone know what could be the problem, it worked with 0.6.33 to
0.6.34 but seems now it doesnt.
Posted via

More information about the nginx mailing list