Nginx error

Max maxbear at
Tue Mar 10 17:18:30 MSK 2009


I just changed worker processes to 2 and worker connections to 1024.

But there problem is still there. It redirects me to 50x page from time to

The only way to make it work again is, kill all nginx process, restart it,
and then I must type:

/usr/bin/spawn-fcgi -a -p 9000 -u nginx  -g nginx -f
/usr/bin/php-cgi -P /var/run/

in order to make it works again. It seems the problem is related to fastcgi.

I am using 0.6.33-1.el5(nginx) and 1.4.18-1.el5.rf(lighttpd). Anyone got any
idea what this happen?


On Mon, Mar 9, 2009 at 2:09 AM, Cliff Wells <cliff at> wrote:

> On Sun, 2009-03-08 at 21:29 +0800, Max wrote:
> > Hello,
> >
> > My nginx server always redirect all traffic to 50x page from time to
> > time. I can't even restart it. I need to reboot.
> You *can't* restart Nginx, or restarting it doesn't help?
> > The worker_processes  5 and worker_connections is 4096, is it too
> > many?
> Unless you have 5 or more cores, then that's almost certainly too many.
> Try one worker process per core (maybe even just one, unless you are
> serving tons of static files) and 1024 worker_connections.
> I have no idea if this is related to the 50x errors you get.
> > How can I check what is the case of the problem? Thanks.
> I'd start with the error log and some details about your setup (starting
> with your OS, Nginx version, and maybe what you are serving).
> Regards,
> Cliff
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the nginx mailing list