Compilation of Nginx on Solris 10 as 64bit

W-Mark Kubacki wmark+nginx at
Thu Oct 8 18:45:54 MSD 2009

2009/10/7 arin <nginx-forum at>:
> I tried that either, won't work
> also I have tried to compile in 32bit mode (different env !!!)
> Undefined                       first referenced
>  symbol                             in file
> ngx_atomic_fetch_add                objs/src/core/ngx_resolver.o
> ngx_atomic_cmp_set                  objs/src/core/nginx.o
> ngx_cpu_pause                       objs/src/core/ngx_spinlock.o
> ld: fatal: Symbol referencing errors. No output written to objs/nginx
> make[1]: ***  Error 1
> make[1]: Leaving directory `/export/home/arin/nginx-0.7.62'
> make: ***  Error 2
>  seems that we have problem with solaris and the current version of nginx
> WHAT VERSION OF NGINX is can be built with Solaris 10 (latest release ) and SunStudio 12.1 ?
> I will be happy to be the nginx QA  (at least for the basic sanity of compilation and basic functionality test and some performance tests).
> for Solaris 10
> however I will need some help from the community as I'm new to nginx (not to solaris :)

Try my libatomic patches from this list. The referenced symbols should
be found, even without GCC as libatomic compiles fine with SunC.


More information about the nginx mailing list