Fwd: Not forwarding requests to FastCGI server on Windows

jlist9 at gmail.com jlist9 at gmail.com
Mon Oct 19 08:29:02 MSD 2009

Please ignore my last email. It turned out that there were
some nginx processes that are already in memory, and they didn't
take the conf file somehow.

===8<==============Original message text===============

I'm new to nginx. I'm trying to set up nginx 0.7.62 with a web.py
application via FastCGI. The same app works with another web server.

I ran the web.py app with "code.py fastcgi 8080"

I tried the config below. The server starts fine and loads the
index.html file for "/". But if I try /abcd, I get "404 Not Found"
in the browser and this error in nginx error.log:

2009/10/18 19:57:06 [error] 4568#1572: *9 CreateFile() "D:\Internet\Servers\nginx-0.7.62/html/abcd" failed (2: The system cannot find the file specified), client:, server: localhost, request: "GET /abcd HTTP/1.1", host: ""

So it looks like it's not sending the request to the backend FastCGI
server at all. Any idea why this is happening?

    server {
        listen 80;
        server_name _;
        index  index.html;

        location / {
            fastcgi_param PATH_INFO $fastcgi_script_name;
            fastcgi_param REQUEST_METHOD $request_method;
            fastcgi_param QUERY_STRING $query_string;
            fastcgi_param CONTENT_TYPE $content_type;
            fastcgi_param CONTENT_LENGTH $content_length;
            fastcgi_param SERVER_PROTOCOL $server_protocol;
            fastcgi_param SERVER_PORT $server_port;
            fastcgi_param SERVER_NAME $server_name;
            fastcgi_pass_header Authorization;
            fastcgi_intercept_errors off;

More information about the nginx mailing list