compiling nginx on solaris 10 using pre-built openssl, pcre packages

muhammad akl muhammad.akl at
Fri Jan 8 22:29:27 MSK 2010

I'm trying to build nginx from source on solaris 10 with openssl and pcre
support, the problem now when executing the configure script it shows that
it can not found either openssl or pcre on the the system although they are
already there. I've tried several options like
--with-ld-option="-L/usr/local/ssl/lib" and the same also with pcre with no

also when tried to compile nginx in 64 bit mode, it compiles fine but when
starting it, the following error was shown in terminal : nginx: fatal: hardware capability unsupported: 0x2000

after surfing google i got this link

the last lines were interesting enough:

 the "rep; nop" is used instead of "pause" to avoid the "[ PAUSE ]" hardware
> capability added by linker because Solaris/i386 does not know about it, so i
> edited the corresponding file src/os/unix/ file and
> changed this line at the end of the file :
pause  to rep; nop and and the problem solved

Now is there any particular way to force nginx to work with the pre-bult
packages ? i've done almost anything compiled openssl & pcre in different
paths , made symlinks but with no success.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the nginx mailing list