GZIP Issues in 0.7 vx 0.8

Kevin nginx-forum at nginx.us
Sat Oct 30 02:47:20 MSD 2010

I ran into an issue the last couple days where we noticed some files
were being gzipped from a site (in a reverse proxy config) and others
were not. Initially we believed it to be due to the size of the buffer
so we increased it, enormously. Yet, no resolution.

We tried buffering, caching, compression levels, vary any, proxied, etc.
We simply couldn't find the issue. We went with a hail mary and built
0.8 (newest) and the issue is now resolved.

Is there a bug or an issue with 0.7 and gzip in a reverse proxy config
vs 0.8? Apparently there is something but I wanted to point out we ran
into this issue. We can also provide configs to duplicate this problem.

One last thing:
There was not a gzip_disable string, no changes in mime.types, even
removed all settings except gzip on;. This issue occurred with both gzip


Posted at Nginx Forum: http://forum.nginx.org/read.php?2,145872,145872#msg-145872

More information about the nginx mailing list