nginx make error, when --with-http_perl_module

Maxim Dounin mdounin at
Wed Sep 22 20:33:25 MSD 2010


On Wed, Sep 22, 2010 at 10:29:57AM -0400, subeen wrote:

> I am getting the same error (in centos54 nginx-0.7.67). I also tried the
> patch, just edited the respective files by myself, but still getting the
> error.
> This is the error message I am getting:

> make[2]: Entering directory
> `/root/nginx-0.7.67/objs/src/http/modules/perl'
> gcc -c  -I ../../../../../src/core -I ../../../../../src/event -I
> ../../../../../src/os/unix -I ../../../../../src/http -I
> ../../../../../src/http/modules -I ../../../../../src/http/modules/perl
> -I ../../../../../objs -I /root/pcre-8.10 -I
> ../../../../..//openssl/include  -D_REENTRANT -D_GNU_SOURCE
> -fno-strict-aliasing -pipe -Wdeclaration-after-statement
> -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
> -I/usr/include/gdbm
> -I/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE -g  -O  
> -DVERSION=\"0.7.67\" -DXS_VERSION=\"0.7.67\" -fPIC
> "-I/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE"   nginx.c


In 0.7.67 you have to use updated patch, see here:

Maxim Dounin

More information about the nginx mailing list