0.9.3 on OpenBSD 4.8

Piotr Sikora piotr.sikora at frickle.com
Mon Jan 3 23:16:48 MSK 2011


> 0.2) How come "PCRE library is not used"?

Do you have pcre installed? (pkg_info | grep ^pcre)

> 1) When issuing make for the first time i got these errors with the
> Form Input module:
> (...)

You need NDK module (https://github.com/simpl/ngx_devel_kit).

> 2) After removing the appropriate --add-module line, doing .configure
> and make again, i got another error:
> cd /usr  && make CFLAGS="-O2 -fomit-frame-pointer -pipe "  CC="gcc"
> MD5_ASM_OBJ= clean libmd5.a
> make: don't know how to make clean. Stop in /usr.
> *** Error code 2
> This one lost me. Are there any technicalities with OpenBSD's make or
> am i borking it somewhere?

You've broken something, nginx works just fine on OpenBSD.

Best regards,
Piotr Sikora < piotr.sikora at frickle.com >

More information about the nginx mailing list