Error with http_perl_module

Igor Sysoev igor at
Thu May 26 11:40:48 MSD 2011

On Wed, May 25, 2011 at 11:03:52PM -0400, Parker, Joshua wrote:
> I am trying to upgrade to 1.0.2, but I am getting an install error. Any help is greatly appreciated.

> -lcrypt -lpcre -lssl -lcrypto -ldl -lz \
> -Wl,-E -fstack-protector -L/usr/local/lib -L/usr/lib/perl/5.10/CORE -ldl -lm -lpthread -lc -lcrypt
> objs/src/http/modules/perl/ngx_http_perl_module.o: In function `ngx_http_perl_init_interpreter':
> /usr/local/src/nginx-1.0.2/src/http/modules/perl/ngx_http_perl_module.c:516: undefined reference to `Perl_sys_init'

What does "perl -MExtUtils::Embed -e ldopts" show ?

Igor Sysoev

More information about the nginx mailing list