RHEL 6, nginx and parse fails

dignus nginx-forum at nginx.us
Thu Apr 19 14:46:46 UTC 2012

Hi all,

Today I updated 2 of my RHEL 6 boxes to the latest version of all
installed packages including Nginx from the nginx repository.

Since then both reload & configtest won't work, the error I'm seeing is

nginx object version 0.8.54 does not match bootstrap parameter 1.0.14 at
/usr/lib64/perl5/XSLoader.pm line 94.
Compilation failed in require.
BEGIN failed--compilation aborted.
2012/04/19 16:23:01 [alert] 11485#0: perl_parse() failed: 2

Any idea what's happening here?

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,225519,225519#msg-225519

More information about the nginx mailing list