Problem with try files: =404 results in php files being downloaded instead of parsed by php

Xaymar nginx-forum at
Sun Jun 24 22:24:01 UTC 2012


I tried changing my template configuration so that it would show "404
not found" instead of "No input file specified." but to my surprise,
try_files did something completely unpredictable and now I'm stuck with
"No input file specified.". To be exact I tried changin this:
> try_files "$uri" "$uri/" "/index.php";
into this:
> try_files "$uri" "$uri/" "/index.php" =404;
which then resulted in nginx sending the php file as
application-octet-stream, instead of parsing it through the fastcgi
handler. How do I do the above right, if not with the try_files syntax?

My configurations:
/etc/nginx/nginx.conf -
/etc/nginx/mime.types -
/etc/nginx/conf.d/default.conf -
/etc/nginx/conf.d/mime.types -
/etc/nginx/inc.d/global.conf -
/etc/nginx/inc.d/php.conf -
/etc/nginx/sites-available/ -
The corresponding line is in /etc/nginx/inc.d/global.conf:
> Line 21:                try_files "$uri" "$uri/" "/index.php";

Thanks in advance,

Posted at Nginx Forum:,227833,227833#msg-227833

More information about the nginx mailing list