1.7.01 mainline on debian has installed a wrong package

Jonathan Matthews contact at jpluscplusm.com
Sun Apr 27 21:55:23 UTC 2014

On 27 April 2014 22:37, ura <nginx-forum at nginx.us> wrote:
> after running the upgrade to 1.7.01 mainline version on debian, the nginx
> version check (service nginx -V) lists:
> 0.91-ubuntu1 - even though 1.7.01 is listed in the package manager in
> debian.
> does this mean that debains repos are serving an incorrect package?

You will have more than one repo enabled which is capable of providing
the "nginx" package, I suspect.

Try "apt-cache policy nginx" (or nginx-full, depending on what you
think you have installed) to see the versions your system knows about,
and where it thinks they come from. Then work out how to get the
correct version: disable a repo, or install a different package name,
or apt-pin a version, or something else; you'll have to have a good
poke at it.


More information about the nginx mailing list