1.7.01 mainline on debian has installed a wrong package

Jonathan Matthews contact at jpluscplusm.com
Sun Apr 27 22:11:17 UTC 2014

On 27 April 2014 23:00, ura <nginx-forum at nginx.us> wrote:
> thanks for assisting. i ran that command and see 3 repos which provide
> nginx. from what i see there, the 1.7.0-1 wheezy package is the candidate
> and also has been installed.
> i just checked my local development machine which is running lmde - the
> version of nginx is also the same spurious ubuntu 0.91 version.. yet the 2
> machine are using different repos.
> i am not seeing 0.91 listed anywhere other than when i run service nginx -V

"which nginx" will show you the specific binary you're running when
you execute nginx-V. It may well be a different one from that which
your initscript invokes.

"dpkg -L nginx" (or whichever package you have installed) will show
you which files on disk are from that package.

I suspect you'll discover your actual problem by examining the the
output of these two commands.


More information about the nginx mailing list