Compile nginx 1.4.7 --with-http_rewrite_module Error

Steve Holdoway steve at
Tue May 13 05:09:13 UTC 2014

On Tue, 2014-05-13 at 11:25 +0800, gaoping at wrote:
> hi:
>      I compiled nginx1.4.7,add
> to --with-pcre=/root/nginx/pcre-8.34 --with-http_rewrite_module parameter;An error occurred :./configure: error: invalid option "--with-http_rewrite_module" ,Trouble who can talk about what is the problem

It's on by default. You can switch it off with the
--without-http_rewrite_module flag.



Steve Holdoway BSc(Hons) MIITP
Skype: sholdowa

More information about the nginx mailing list