13: Permission denied while connect server using https through nginx

malintha nginx-forum at nginx.us
Tue Feb 3 06:31:18 UTC 2015


My nginx configurations are as follows. I am going to connect running server
UI from my machine through nginx. 

server {
   listen       443;
   server_name  mgt.wso2bps.malintha.com;
   ssl on;
   ssl_certificate /etc/nginx/ssl/wso2bps.crt;
   ssl_certificate_key /etc/nginx/ssl/wso2bps.key;

   location / {


Server is running and I can access the UI directly from my computer. But
when I access it through nginx it goves me 502 bad gateway on browser and
following error in nginx error log

2015/02/03 13:15:43 [crit] 5721#0: *7 connect() to failed (13:
Permission denied) while connecting to upstream, client:,
server: mgt.wso2bps.malintha.com, request: "GET / HTTP/1.1", upstream:
"", host: "mgt.wso2bps.malintha.com"

I tried run server/stop server but both incidents gives same error in nginx
side. What may be the reason for this error?

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,256412,256412#msg-256412

More information about the nginx mailing list