Nginx 1.9.11 and OpenSSL 1.0.2G - HTTP2, but no ALPN negotiated.

Alt nginx-forum at
Thu Mar 3 16:46:54 UTC 2016


Jim Ohlstein Wrote:
> If you need http2 there is always the option to compile your own nginx
> binary against a more modern version of OpenSSL than what your
> operating system provides, or to change operating systems to one which
> provides such an OpenSSL version. 

Yes, it's what I'm doing with LibreSSL :-)

But HTTP/2 works also very well with NPN and OpenSSL 1.0.1... sadly it'll be
less useful when Google would have dropped support for NPN.

Best Regards

Posted at Nginx Forum:,265036,265054#msg-265054

More information about the nginx mailing list