nginx: invalid option: "-s start"

Patrick Chkoreff pc at
Thu May 31 19:55:11 UTC 2018

helloData wrote on 05/31/2018 03:37 PM:
> Hi,
> I am trying nginx for the first time. I installed and tried "sudo nginx -s
> start". However, I got error. Here is the detail:
> a) I am using Ubuntu on x64 (LinuxMint Sonya). 
> b) Configuration file is located at  /etc/nginx
> c) There is no initially, but it appears at /var/run when I run
> "sudo nginx"
> d) After step (c), I ran "sudo nginx -s start" but got this error "nginx:
> invalid option: "-s start".
> e) However, after the failed attempt (d), I could do "sudo nginx -s stop"
> without any error.
> Any way to solve the error problem?

I looked in the man page, and "start" is not a valid option for -s.  The
recognized options are stop, quit, reopen, reload.

To start nginx, just use:

sudo nginx

-- Patrick

P.S. Or of course if you have /etc/init.d/nginx set up, just say:

sudo service nginx start


sudo service nginx restart

More information about the nginx mailing list