Dave - is there any common reason that might be happening intermittently on just about any controller/action combination for an app?<br><br><div class="gmail_quote">On Mon, Mar 10, 2008 at 11:04 AM, AnÝbal Rojas &lt;<a href="mailto:anibalrojas@gmail.com" target="_blank">anibalrojas@gmail.com</a>&gt; wrote:<br>

<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">James,<br>
<br>
 &nbsp; &nbsp;As some kind of &quot;last resource&quot;...<br>
<br>
 &nbsp; &nbsp;What about hacking a quick controller to respond with the<br>
offending codes and check how are they being handled?<br>
<br>
--<br>
<font color="#888888">AnÝbal<br>
</font><div><div></div><div><br>
On Tue, Mar 11, 2008 at 10:08 AM, James Golick &lt;<a href="mailto:jamesgolick@gmail.com" target="_blank">jamesgolick@gmail.com</a>&gt; wrote:<br>
&gt; Still says 200. Somebody is throwing this error and won&#39;t admit to it. I&#39;m<br>
&gt; guessing it&#39;s mongrel, but at this point, I&#39;ve really got no idea.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; On Mon, Mar 10, 2008 at 10:28 AM, Igor Sysoev &lt;<a href="mailto:is@rambler-co.ru" target="_blank">is@rambler-co.ru</a>&gt; wrote:<br>
&gt;<br>
&gt; &gt;<br>
&gt; &gt; On Mon, Mar 10, 2008 at 10:18:53AM -0400, James Golick wrote:<br>
&gt; &gt;<br>
&gt; &gt; &gt; That&#39;s the really weird thing - nothing.<br>
&gt; &gt; &gt;<br>
&gt; &gt; &gt; It seems like maybe my upstream is responding with 200, but actually<br>
&gt; showing<br>
&gt; &gt; &gt; a 500-style error?<br>
&gt; &gt;<br>
&gt; &gt; You may log $upstream_status in access_log to see an exact upstream<br>
&gt; status.<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt; &gt; On Mon, Mar 10, 2008 at 10:10 AM, Igor Sysoev &lt;<a href="mailto:is@rambler-co.ru" target="_blank">is@rambler-co.ru</a>&gt; wrote:<br>
&gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; On Mon, Mar 10, 2008 at 10:06:27AM -0400, James Golick wrote:<br>
&gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; Nothing.<br>
&gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; I&#39;m thinking now that these must be coming occasionally from my<br>
&gt; upstream<br>
&gt; &gt; &gt; &gt; &gt; servers.<br>
&gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; I mean what do you see in access_log - 500, 502, etc ?<br>
&gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; Thanks for your help<br>
&gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; On Mon, Mar 10, 2008 at 10:02 AM, Igor Sysoev &lt;<a href="mailto:is@rambler-co.ru" target="_blank">is@rambler-co.ru</a>&gt;<br>
&gt; wrote:<br>
&gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt; On Mon, Mar 10, 2008 at 09:55:23AM -0400, James Golick wrote:<br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt; &gt; Nginx will always log an error when there&#39;s a 500?<br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt; Yes, at least I have tried to log them all. The log is single way<br>
&gt; &gt; &gt; &gt; &gt; &gt; to know about the problems.<br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt; So what do you see - 500, 502, 503, or 504 ?<br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt; --<br>
&gt; &gt; &gt; &gt; &gt; &gt; Igor Sysoev<br>
&gt; &gt; &gt; &gt; &gt; &gt; <a href="http://sysoev.ru/en/" target="_blank">http://sysoev.ru/en/</a><br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt; --<br>
&gt; &gt; &gt; &gt; Igor Sysoev<br>
&gt; &gt; &gt; &gt; <a href="http://sysoev.ru/en/" target="_blank">http://sysoev.ru/en/</a><br>
&gt; &gt; &gt; &gt;<br>
&gt; &gt; &gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt; --<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt; &gt; Igor Sysoev<br>
&gt; &gt; <a href="http://sysoev.ru/en/" target="_blank">http://sysoev.ru/en/</a><br>
&gt; &gt;<br>
&gt; &gt;<br>
<br>
</div></div></blockquote></div><br>