[PATCH] Upstream: fix warning when building with BoringSSL