[PATCH 17 of 31] Gzip static: "always" parameter in "gzip_static" directive

Zhu Qun-Ying zhu.qunying at gmail.com
Mon Jun 27 22:01:01 MSD 2011


It would be more readable if numerical definition of off/on/always use  
enum type in stead of plain number directly,
like:
enum {
	NGX_HTTP_GZIP_STATIC_OFF,
	NGX_HTTP_GZIP_STATIC_ON,
	NGX_HTTP_GZIP_STATIC_ALWAYS,
};

Do you think so?

On Mon, 27 Jun 2011 10:06:47 -0700, Maxim Dounin <mdounin at mdounin.ru>  
wrote:

> # HG changeset patch
> # User Maxim Dounin <mdounin at mdounin.ru>
> # Date 1309187001 -14400
> # Node ID 31aaaef96cb108e118afe407346cb4f04a444437
> # Parent  d43c81dbcd7f0774d72720f7bc9d65aa9bff0cc2
> Gzip static: "always" parameter in "gzip_static" directive.
>
> With "always" gzip static returns gzipped content in all cases, without
> checking if client supports it.  It is usefull if you has no gunzipped  
> files
> on disk anyway.
>
> diff --git a/src/http/modules/ngx_http_gzip_static_module.c  
> b/src/http/modules/ngx_http_gzip_static_module.c
> --- a/src/http/modules/ngx_http_gzip_static_module.c
> +++ b/src/http/modules/ngx_http_gzip_static_module.c
> @@ -10,7 +10,7 @@
> typedef struct {
> -    ngx_flag_t  enable;
> +    ngx_uint_t  enable;
>  } ngx_http_gzip_static_conf_t;
> @@ -21,14 +21,22 @@ static char *ngx_http_gzip_static_merge_
>  static ngx_int_t ngx_http_gzip_static_init(ngx_conf_t *cf);
> +static ngx_conf_enum_t  ngx_http_gzip_static[] = {
> +    { ngx_string("off"), 0 },
> +    { ngx_string("on"), 1 },
> +    { ngx_string("always"), 2 },
> +    { ngx_null_string, 0 }
> +};
> +
> +
>  static ngx_command_t  ngx_http_gzip_static_commands[] = {
>     { ngx_string("gzip_static"),
>        NGX_HTTP_MAIN_CONF|NGX_HTTP_SRV_CONF|NGX_HTTP_LOC_CONF|NGX_CONF_FLAG,
> -      ngx_conf_set_flag_slot,
> +      ngx_conf_set_enum_slot,
>        NGX_HTTP_LOC_CONF_OFFSET,
>        offsetof(ngx_http_gzip_static_conf_t, enable),
> -      NULL },
> +      &ngx_http_gzip_static },
>       ngx_null_command
>  };
> @@ -95,7 +103,12 @@ ngx_http_gzip_static_handler(ngx_http_re
>          return NGX_DECLINED;
>      }
> -    rc = ngx_http_gzip_ok(r);
> +    if (gzcf->enable == 1) {
> +        rc = ngx_http_gzip_ok(r);
> +
> +    } else {
> +        rc = NGX_OK;
> +    }
>     clcf = ngx_http_get_module_loc_conf(r, ngx_http_core_module);
> @@ -160,10 +173,12 @@ ngx_http_gzip_static_handler(ngx_http_re
>          return NGX_DECLINED;
>      }
> -    r->gzip_vary = 1;
> +    if (gzcf->enable == 1) {
> +        r->gzip_vary = 1;
> -    if (rc != NGX_OK) {
> -        return NGX_DECLINED;
> +        if (rc != NGX_OK) {
> +            return NGX_DECLINED;
> +        }
>      }
>     ngx_log_debug1(NGX_LOG_DEBUG_HTTP, log, 0, "http static fd: %d",  
> of.fd);
> @@ -261,7 +276,7 @@ ngx_http_gzip_static_create_conf(ngx_con
>          return NULL;
>      }
> -    conf->enable = NGX_CONF_UNSET;
> +    conf->enable = NGX_CONF_UNSET_UINT;
>     return conf;
>  }
> @@ -273,7 +288,7 @@ ngx_http_gzip_static_merge_conf(ngx_conf
>      ngx_http_gzip_static_conf_t *prev = parent;
>      ngx_http_gzip_static_conf_t *conf = child;
> -    ngx_conf_merge_value(conf->enable, prev->enable, 0);
> +    ngx_conf_merge_uint_value(conf->enable, prev->enable, 0);
>     return NGX_CONF_OK;
>  }
>
> _______________________________________________
> nginx-devel mailing list
> nginx-devel at nginx.org
> http://nginx.org/mailman/listinfo/nginx-devel



More information about the nginx-devel mailing list