"add_header X-Upstream-Response-Time $upstream_response_time" not working

Maxim Dounin mdounin at mdounin.ru
Wed Oct 8 22:51:35 MSD 2008


On Wed, Oct 08, 2008 at 05:55:16PM +0000, Matt Albright wrote:

>I'm using nginx 0.5.35 (I know, we'll upgrade here soon) and have
>$upstream_response_time in the access log, and it works great.
>To track down a problem, I wanted to add a header to nginx's response that shows
>the response time of the upstream server, so I tried:
>add_header X-Upstream-Response-Time $upstream_response_time
>Which seems like it would work, based on the docs for add_header, but I get:
>X-Upstream-Response-Time: 1223488205.821
>Which looks like a unix time to me, which isn't very useful.

Yep.  Since header is sent before we got whole response from 
upstream - we have no upstream end time at this point.

>Is there any way to get what I want?  I tried putting the add_header in http,
>server, and location blocks, but all of them gave me a unix time.

Currently no, only logging will work.

Probably it's a good idea to introduce another variable that will 
be available as soon as we got response header from upstream.

Maxim Dounin

More information about the nginx mailing list