Update of nginx

B.R. reallfqq-nginx at yahoo.fr
Wed Dec 14 03:25:18 UTC 2011

Hi everyone,

First of all: shame on me! :oP

I deleted the whole nginx directory, reinstalled the new version... and the
headers still got stuck on 1.0.9...
Then... I discovered that the executable used was /usr/local/sbin/nginx and
not /usr/local/nginx/sbin/nginx... Is the first file a link? Yes, but not

I wiped it out, recreated it as symbolic and now I get the 1.1.11 up and
running :o)

Thanks for your time btw,
*B. R.*

On Tue, Dec 13, 2011 at 14:47, B.R. <reallfqq-nginx at yahoo.fr> wrote:

> Thanks Sharl, Antonio,
> Sharl, I used the 'sudo make install' command to be sure the install would
> get the admin rights.
> 'which nginx' won't work, but '/usr/local/nginx/sbin/nginx -v' gives me
> the 1.1.11 version.
> Antonio, I tried your commands, but I already had my browser configured so
> that its cache is deleted when I exit.
> I tried again this morning after I booted my computer again and I still
> gets the 1.0.9 header version...
> I made a chown on the /usr/local/nginx' directory so the nginx user and a
> group not related to it are the owners of all the files inside. I remember
> having seen some subdirectories (such as 'conf') owned by the user root and
> not nginx.
> Does that could have an impact? I doubt it, since the 'other' rights are
> still set to 'read'. It was maybe one of my 'security' tweaks of which I
> don't really know the useness.
> If anyone has an idea apart from wiping out the whole directory (which
> would be far away the 'hot update' feature idea planted in nginx), I would
> be glad to take it...
> ---
> *B. R.*
> On Tue, Dec 13, 2011 at 02:49, António P. P. Almeida <appa at perusio.net>wrote:
>> On 13 Dez 2011 06h35 WET, reallfqq-nginx at yahoo.fr wrote:
>> > [1  <multipart/alternative (7bit)>]
>> > [1.1  <text/plain; UTF-8 (7bit)>]
>> > Hello,
>> >
>> > I am encountering a problem while updating my nginx server.
>> >
>> > I first configured and built the new version 1.1.11.  I then stopped
>> > the server, checked it has been done, executed the make install and
>> > checked the configuration with the '-t' option which was OK.  I then
>> > started the new version, but I am still seeing the 1.0.9 number in
>> > the header of the pages loaded in my browser. I hit F5 several times
>> > to be sure it wasn't the cache.
>> F5 -> usually reload (loads from cache if possible - check network
>> panel on firebug or chrome browser inspector for confirmation)
>> Ctrl + F5 -> reload without fetching from cache.
>> > What did I miss?
>> Perhaps the above.
>> Also try to use something like curl for checking, not a browser:
>> curl -I <mysite>
>> Check the headers.
>> --- appa
>> _______________________________________________
>> nginx mailing list
>> nginx at nginx.org
>> http://mailman.nginx.org/mailman/listinfo/nginx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.nginx.org/pipermail/nginx/attachments/20111213/cf722d66/attachment-0001.html>

More information about the nginx mailing list