Nginx server_name command being ignored

Jonathan Matthews contact at
Sat Dec 15 00:22:31 UTC 2012

On 14 December 2012 23:54, constable1 <nginx-forum at> wrote:
> Hi Jonathan, Francis,
> I've just tried on the server "ping test", and I get no packet loss, it all
> seems to be looking fine. I also tried "curl -i http://test/" and I get the
> output as the code that makes up the html of my page, so it appears that
> nginx is working fine, but when I try going to http://test/ on another
> machine on my home network then I get nothing, I agree that this must be
> some kind of DNS issue here, but how does one go about fixing it?

Work put how the machines *should* be resolving "test" to an IP
address, and add entries so that they *can*.
This may be your hosts file, if you're doing internal, LAN-only
development, or a DNS server somewhere.

This is somewhat of out of scope for the nginx list now, though ... :-)

Jonathan Matthews // Oxford, London, UK

More information about the nginx mailing list