Using Crypt::OpenSSL::RSA with http_perl_module problem

Igor Sysoev igor at
Wed Dec 26 17:08:59 UTC 2012

On Dec 26, 2012, at 20:40 , kalpesh.patel at wrote:

> Igor:
> I had tried that before but now I tried with following two which still
> errors out with same exact place and error:
> env PERL5LIB=/usr/local/lib/perl/5.12.4/:/usr/lib/perl/5.12.4/;
> env LD_LIBRARY_PATH=/usr/lib/perl/5.12.4/auto/Crypt/OpenSSL/RSA/;

Sorry, I did not look your first message with strace.
Perl already knows about these pathes, but it seems
this perl installation is broken:

Perl found right directory but then tries to look "RSA." instead of "":

{st_mode=S_IFDIR|0775, st_size=4096, ...}) = 0
stat("/usr/local/lib/perl/5.12.4/auto/Crypt/OpenSSL/RSA/RSA.", 0x16d0e68) =
-1 ENOENT (No such file or directory)

Then it looks "-L/..." directories which are actually linking parameters: 

stat("-L/usr/local/lib/perl/5.12.4/auto/Crypt/OpenSSL/RSA", 0x16d0e68) = -1
ENOENT (No such file or directory)
stat("-L/usr/lib/perl/5.12/auto/Crypt/OpenSSL/RSA", 0x16d0e68) = -1 ENOENT
(No such file or directory)

Igor Sysoev

More information about the nginx mailing list