Strange php-fpm problem...

gcaplan nginx-forum at
Wed Mar 14 14:10:46 UTC 2012

Hi folks

Not strictly an Nginx issue, but got some great advice on php-fpm here
before so though I'd trade on your generosity...


1) php-fpm is running fine on Ubuntu 12

2) I stupidly configure xdebug to run on the same port as php-fpm and
try to restart php-fpm

3) I correct the misconfiguration, but now php-fpm won't start at all,
even after a reboot.

4) The only diagnostics I can find are in boot.log: "Starting FastCGI
server: No servers have been defined." No hits at all for this in
Google. I have set up a pool which was working fine before the


1) If I run ">service php5-fpm start" there is a long pause, then the
shell outputs "killed"

2) There is nothing in the php5-fpm log, even with log level debug, so
it seems to hit the issue early in the process.

3) I've tried restarting with the xdebug config commented out, and with
Nginx stopped.

4) I've tried rebooting

5) There's no orphaned pid file in /var/run, and no php-fpm processes

I've run out of ideas. Any help would be more than welcome.

Posted at Nginx Forum:,223827,223827#msg-223827

More information about the nginx mailing list