writev function not implemented

Rangel, Raul Raul.Rangel at disney.com
Mon Aug 5 22:22:57 UTC 2013

So I just tried you little script inside my container (AUFS on top of ZFS):

root at 47dfdb95e2a6:/# ./a.out 
writev: Function not implemented
root at 47dfdb95e2a6:/#

Then I tried my script outside of the container (ZFS):
me at slagathor:~/Projects/service/services/upload$ ./a.out 

Here is my uname:
Linux slagathor 3.8.0-27-generic #40~precise3-Ubuntu SMP Fri Jul 19 14:38:30 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The plot thickens....

-----Original Message-----
From: nginx-bounces at nginx.org [mailto:nginx-bounces at nginx.org] On Behalf Of Jérôme P.
Sent: Monday, August 05, 2013 4:16 PM
To: nginx at nginx.org
Subject: Re: RE: writev function not implemented

Rangel, Raul wrote in post #1117817:

> So my assumption is that AUFS does not support writev? So I need to 
> somehow mount a different filesystem?

I wrote a quick and dirty C program to test writev() on AUFS, and it worked like a charm here (3.8 Debian kernel).


What's the *underlying* filesystem? ZFS?

Posted via http://www.ruby-forum.com/.

nginx mailing list
nginx at nginx.org

More information about the nginx mailing list