502 bad gateway error with php5-fpm on Debian 7

GASPARD Kévin list-reader at koshie.fr
Wed Feb 20 22:54:08 UTC 2013

> On Wed, Feb 20, 2013 at 11:27:04PM +0100, GASPARD Kévin wrote:
> Hi there,
>> I'm using Nginx 1.2.1 on Debian Wheezy 64 bits, I want to host some
>> personals website on my dedicated server. I've installed php5-fpm,  
>> looked
>> at the configuration file which is /etc/php5/fpm/pool.d/www.conf and the
>> "listen" parameters is '/var/run/php5-fpm.sock'.
> So your fastcgi server is expected to be at /var/run/php5-fpm.sock.
>   ls -l /var/run/php5-fpm.sock

srw-rw-rw- 1 root root 0 Feb 20 14:08 /var/run/php5-fpm.sock

> should show you that it really is there.

I forget to say, but yes it's here and I've runned the daemon php-fpm.

>> #                fastcgi_pass;
>> 		fastcgi_pass unix:/var/run/php5-fpm.sock;
> This looks like it *used to* try to access, but now it
> accesses the expected socket.

Yeah, also forget to say that but this configuration was first used on  
CentOS 6 and it worked well.

>> 2013/02/20 23:19:25 [error] 17211#0: *207 connect() failed (111:
>> Connection refused) while connecting to upstream, client:  
>> server: subdomain.koshie.fr, request: "GET /wp-admin/info.php HTTP/1.1",
>> upstream: "fastcgi://", host: "blog.koshie.fr"
> This says it *actually* tried to access, and failed.

Seems logical because I ask to use /var/run/php5-fpm.sock instead of the  
commented value in /etc/nginx/nginx.conf, right?

> The nginx config you showed is not the one that the running nginx is
> using when it created this log file.

I've pasted a working vhost configuration file and pasted an error on an  
other configuration file but they are identical except for document root  
and domain. To create this file I've used 'cp' and modified it.

> Does the appropriate "nginx -t" show any problems? Does "nginx -s reload"
> give any indication that it did not reload correctly?
> 	f

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

And no output for 'nginx -s reload'.

Thanks for your answer.

Cordially, Koshie

Sorry for my english, I'm trying the best in each e-mail writing. Tell me  
if I'm not clear enough.
This mail account is only for list reading, to contact me send an e-mail  
at kevingaspard at koshie.fr

More information about the nginx mailing list