1.3.11 Issues?

digitalpoint nginx-forum at nginx.us
Tue Jan 15 01:55:43 UTC 2013

Well... the underlying errors went away, but it seems the new SPDY patch
broke being able to handle multiple hosts on the same SPDY connection now
(it worked under 1.3.10 just fine).

For example, we have a SSL cert for both digitalpoint.com and dpstatic.com
(dpstatic.com is a cookieless domain for serving static content), so SPDY
attempts to use the same connection for multiple hosts.  See SPDY session
list here: 

With the SPDY patch for 1.3.11, now requests to *.dpstatic.com are
*actually* being sent to digitalpoint.com (and getting a file not found). 
So somehow during a SPDY connection, the host for an individual request is
being ignored somewhere along the way.

Top browser is Chrome (SPDY connection), bottom browser is Safari (no SPDY
support)... the end result is a SPDY connection will yield different results
vs the "traditional" SSL connection: 

Again, this worked as expected (ability for SPDY to properly share a
connection across multiple hosts) with 1.3.10.

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,235090,235105#msg-235105

More information about the nginx mailing list