104: Connection reset by peer

ron ramos nhadie at gmail.com
Wed May 8 11:29:17 UTC 2013

Hi All,

I understand that this is a generic error, but it has been frustrating
trying to solve this issue and i'm not able to find an answer anywhere.
basically i have an application which is running fine using apache, but we
wanted to try nginx/php5-fpm:

some parts of my application has this connection reset issue, sometimes it
works but inconsistent.
if it does not work, i restart php5-fpm and it will work again, but after
sometime it will have the same issue.

i'm using:

# nginx -v
nginx version: nginx/1.4.0

# php5-fpm -v
PHP 5.4.14-1~precise+1 (fpm-fcgi) (built: Apr 11 2013 17:18:51)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

when i enable debug this is the only thing i can see;

[08-May-2013 18:08:32.545758] DEBUG: pid 358359, fpm_got_signal(), line 72:
received SIGCHLD
[08-May-2013 18:08:32.545884] WARNING: pid 358359, fpm_children_bury(),
line 252: [pool legacy] child 358423 exited with code 3 after 342.958315
seconds from start
[08-May-2013 18:08:32.548943] NOTICE: pid 358359, fpm_children_make(), line
421: [pool legacy] child 359398 started
[08-May-2013 18:08:32.549023] DEBUG: pid 358359, fpm_event_loop(), line
411: event module triggered 1 events

i have tried different config changes like using static instead of
dynamic..increase max_request..increase child ...increase server..etc.

one thing i really need is to identify what is causing that connection peer
but logs is not really helping. i tried strace and it still did not show me

any other way to debug or identify what is causing this issue? totally
clueless right now.

thank you in advanced.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.nginx.org/pipermail/nginx/attachments/20130508/b0197538/attachment.html>

More information about the nginx mailing list