"Dereferencing Pointer To Incomplete Type" on ARM

vindicator nginx-forum at nginx.us
Wed Aug 19 13:15:07 UTC 2015

I swear I had built the hg default version on my AMD64 just fine, but now
I'm doing it on my ARM device running Ubuntu 15.04 with kernel 4.2.
I used the default system openssl, but also tried with the master git
version all with the same result.

Attempts with:
1) ./auto/configure --with-http_ssl_module --with-ipv6
2) ./auto/configure --with-http_ssl_module --with-ipv6 --with-cc-opt="-I
/usr/local/ssl/include -I /usr/local/include" --with-ld-opt="-L
/usr/local/ssl/lib -L /usr/local/lib"
3) ./auto/configure --with-ipv6 --with-http_ssl_module
and of course "make".
src/event/ngx_event_openssl.c: In function ‘ngx_ssl_handshake’:
src/event/ngx_event_openssl.c:1164:31: error: dereferencing pointer to
incomplete type
         if (c->ssl->connection->s3) {
src/event/ngx_event_openssl.c:1165:31: error: dereferencing pointer to
incomplete type
             c->ssl->connection->s3->flags |=

"./auto/configure --with-ipv6" built with no problems.

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,261124,261124#msg-261124

More information about the nginx mailing list