Fastcgi_pass, resolver, and validating functionality.

ahamilton9 nginx-forum at
Wed Dec 7 20:39:11 UTC 2016

I've tried recreating the configuration on my local machine, and it works
just fine. Really confusing. I don't understand why I get absolutely no DNS
traffic on my nginx server (beyond the few calls from other services). Not a
single call from nginx. 

Also, I read in the documentation that "By default, nginx caches answers
using the TTL value of a response", and then everywhere else I'm told it
doesn't. We never had a resolver before I updated to 1.10, and it worked
fine for years. Another mailing list post mentions that the issue of TTLs
being ignored would be "fixed" way back in version 1.1:,217468,217468#msg-217468 Did it get
removed or put into nginx Plus only by version 1.10?

I'm still not sure whats going on, and from my month+ of research, it seems
I'm the only one having this problem...

Posted at Nginx Forum:,271373,271420#msg-271420

More information about the nginx mailing list