502 Bad Gateway once running php on command line

marcusy3k nginx-forum at forum.nginx.org
Wed Mar 23 04:59:32 UTC 2016

I have just installed:
- FreeBSD 10.2
- Nginx 1.8.1
- PHP 5.5.33

Nginx works fine with PHP that the web sites seems ok to run php pages.
However, once I run php on command line (e.g. php -v), the web site will get
"502 Bad Gateway" error, and I find the nginx error log as below:

[error] 714#0: *3 upstream prematurely closed connection while reading
response header from
upstream, client: _____, server: www.____.com, request: "GET / HTTP/1.1",
upstream: "fastcgi://unix:/
var/run/php5-fpm.sock:", host: "_____"

I have tried to use either sock or port, but the problem still exist... any
idea about what's wrong? thanks.

"php -v" shows below:
PHP 5.5.33 (cli) (built: Mar 15 2016 01:22:17) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
    with XCache v3.2.0, Copyright (c) 2005-2014, by mOo
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend
    with XCache Cacher v3.2.0, Copyright (c) 2005-2014, by mOo

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,265576,265576#msg-265576

More information about the nginx mailing list