$upstream_addr returning "-" only on requests with "del" in them

ywarnier nginx-forum at forum.nginx.org
Wed Apr 26 23:17:40 UTC 2017

Hi guys,

I have a problem with some of the requests sent to my Nginx load balancer,
which reports (in the access_log configured to show $upstream_addr) that
$upstream_addr is equal to "-", but only in a weird case where the post
contains the word "del".

I'm using Nginx 1.10.0 packaged in Ubuntu 16.04.4, in a development cluster
of VMs with Nginx serving as load balancer to serve a bunch Drupal 7 sites
that an Apache+modPHP is serving (I could use Nginx+PHP-FPM but that's not
the point here).

So it's a web-facing VM with Nginx that passes to another VM with Apache
(through proxy_pass). No "effective" load balancing (only one upstream
server in the backend block).

I've tried to maintain customizations to a reasonable minimum to avoid
introducing too many variables.

Inside Drupal 7 (which I installed under the Apache backend server), I have
nodes that I would like to edit.

Now, on several nodes, when I edit a textarea with whatever I like,
everything works fine. The request is passed to Nginx, then to Apache, and I
can see that in the access logs for both.

However, if the textarea contains the work "del" (I know... weird), then the
request gets to Nginx and the $upstream_addr is generated as "-" and no
request reaches the upstream server.

How can I debug that?
I've tried putting the error_log to "debug" but it's apparently not an
The access_log provides me with this weird case of $upstream_addr = '-', but
that's all I get...

Thanks for your help!

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,273895,273895#msg-273895

More information about the nginx mailing list