nginx, php7.0-fpm and laravel, not able to set it up when the url has a prefix which the server doesn't have

Plato Puthur plato.puthur at
Sun Aug 5 20:04:59 UTC 2018


I am trying to set up a laravel installation in docker with php-fpm and
nginx server on a separate container. The issue is the laravel is installed
in a path like /home/apps/foo and the url I need is I
thought this was fairly simple, but I am not able to set it up. Here is my
location part in the nginx config

location /v11/ {
                try_files $uri $uri/ /index.php?$query_string;
                location ~ \.php$ {
                        fastcgi_index index.php;
                        fastcgi_pass php_wbv1.0:5000;
                        fastcgi_split_path_info ^(.+\.php)(/.*)$;
                        fastcgi_param SCRIPT_FILENAME
                        fastcgi_param QUERY_STRING $query_string;
                        include fastcgi_params;

I tried rewrite tag, and tried giving alias inside the location block, both
didn't work. The thing is if I remove the /v11/ from the location tag and
the URL, its working without any issues.

What is the right way to do this?


Plato P
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the nginx mailing list