nginx, php7.0-fpm and laravel, not able to set it up when the url has a prefix which the server doesn't have

Plato Puthur plato.puthur at
Mon Aug 6 15:29:40 UTC 2018

Thanks for that input, I changed my config like you said and also set the
fastcgi_param SCRIPT_FILENAME to /path/to/the/index.php;

But I feel like this should be done by the rewrite directive instead of
this way. Now that this is working, can someone please tell me if I can use
the rewrite tag so that I can avoid hardcoding the path everywhere?

On Mon, Aug 6, 2018 at 1:31 PM, Reinis Rozitis <r at> wrote:

> > I tried rewrite tag, and tried giving alias inside the location block,
> both didn't work. The thing is if I remove the /v11/ from the location tag
> and the URL, its working without any issues What is the right way to do
> this?
> The try_files needs probably be changed to:
> try_files $uri $uri/ /v11/index.php?$query_string;
> rr
> _______________________________________________
> nginx mailing list
> nginx at


Plato P
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the nginx mailing list