Operation not permitted) while reading upstream - error log is filled with tons of these

Friscia, Michael michael.friscia at yale.edu
Sat Jan 20 14:31:38 UTC 2018

I tried appling the noperm flag on my test environment, but once I applied the other fix of adding gid/uid to the cifs mount, the chmod() error went away. Now I face a new error that happens infrequently which is rename() fails. I’m guessing the real problem is that without a lot of additional configuration, the nginx cache may not work properly with a cifs mount. My problem is that I’ve forgotten more linux than I remember so I’m stumbling through these errors as they come. But if anyone has seen the rename() error and knows a fix, that would help.

Michael Friscia
Office of Communications
Yale School of Medicine
(203) 737-7932 - office
(203) 544-3282 – mobile
http://web.yale.edu <http://web.yale.edu/>

On 1/20/18, 8:58 AM, "nginx on behalf of Francis Daly" <nginx-bounces at nginx.org on behalf of francis at daoine.org> wrote:

    On Sat, Jan 20, 2018 at 12:47:29PM +0000, Friscia, Michael wrote:
    Hi there,
    > 2018/01/20 07:37:44 [crit] 122598#122598: *91 chmod() "/etc/nginx/cache/nginx2/main/a5/d8/e0/72677057b97aef4eee8e619c49e0d8a5.0000000013" failed (1: Operation not permitted) while reading upstream, client:, server: *.---.com, request: "GET /search/----.profile HTTP/1.1", upstream: "https://urldefense.proofpoint.com/v2/url?u=http-3A__-2D-2D-2D.-2D-2D-2D.-2D-2D-2D.-2D-2D-2D-3A80_search_-2D-2D-2D-2D.profile&d=DwICAg&c=cjytLXgP8ixuoHflwc-poQ&r=wvXEDjvtDPcv7AlldT5UvDx32KXBEM6um_lS023SJrs&m=UJ4oKb6qp-Ebegtr5fHmO-kPUVhfiwYjNdejFmU1NXI&s=U1ihyg-PzcrmSmpX_F1LuqGWbuzXE5j2ntOwmfP51Ac&e=", host: "---.com"
    > The actual setup is that this is on Azure, the storage location /etc/nginx/cache/nginx2 is a mounted file share from Azure storage.
    How precisely is the file share mounted?
    The error indication is that chmod() failed.
    Does chmod() work on that filesystem?
    Can you change the mount options such that chmod() will return success,
    even if it does not actually change the permissions of the file?
    https://urldefense.proofpoint.com/v2/url?u=https-3A__superuser.com_questions_744384_allow-2Dchmod-2Don-2Dcifs-2Dmount&d=DwICAg&c=cjytLXgP8ixuoHflwc-poQ&r=wvXEDjvtDPcv7AlldT5UvDx32KXBEM6um_lS023SJrs&m=UJ4oKb6qp-Ebegtr5fHmO-kPUVhfiwYjNdejFmU1NXI&s=as7NqjlOXjgBHNCelfury7UdUNuN2k7qLdyly5jwGrw&e= suggests
    that "noperm" in the mount options had the desired effect for one user;
    note that that does not seem (to me) to match what the "mount.cifs"
    documentation says, so you'll want to do your own investigation and
    testing before relying on it.
    > Has anyone seen/solved this before?
    I haven't. So the above is "questions" rather than "suggestions how to fix".
    Good luck with it,
    Francis Daly        francis at daoine.org
    nginx mailing list
    nginx at nginx.org

More information about the nginx mailing list