New compilation failure

alang nginx-forum at
Mon Oct 29 20:26:30 UTC 2018

I have an nginx and modsecurity that is installed via our ansible
environment.  It has been running fine for over half a year with no issues. 
This morning I ran it and worked fine.  This afternoon I ran it and it is
erroring.  The environment is git version controlled, so nothing changed in
the scripts.

The following command is run:
cd /root/nginx-1.13.4 && ./configure --user=www-data --group=www-data
--prefix=/opt/nginx --with-debug --with-ipv6 --with-http_ssl_module
--with-http_gzip_static_module --with-http_stub_status_module
--with-cc-opt=-Wno-error --with-ld-opt=
&& make && make install

And the, looks to be, relevant error generated during the make is:
5.0.28/buildout/common/libboost_oxt.a -lstdc++ -lpthread -lm -lrt -lpcre
-lssl -lcrypto -ldl -lz \
objs/addon/src/ngx_http_modsecurity_module.o: In function
undefined reference to `msc_new_transaction_with_id'
collect2: error: ld returned 1 exit status
make[1]: *** [objs/nginx] Error 1
make[1]: Leaving directory `/root/nginx-1.13.4'
make: *** [build] Error 2

Any ideas what the issue is or where to dig?

Posted at Nginx Forum:,281731,281731#msg-281731

More information about the nginx mailing list