Websocket (wss) connection issue (status 200 instead 101) between two nginx systems

YAGA nginx-forum at forum.nginx.org
Mon Apr 20 21:06:14 UTC 2020

Hi Francis,

Many thanks for your message and for your help, it’s very kind of you.

As you suggested, I’ve tried to add these lines on the “black box” side:

proxy_set_header Upgrade $http_upgrade; 
proxy_set_header Connection upgrade; 
proxy_http_version 1.1; 

But unfortunately, without success, these lines didn’t improve the websocket
connection. So, I’ve decided to roll back to previous version without the
connection upgrade on the “black box”.

I’ve tried different changes to the setup and I finally found my mistake, on
the server side I’ve added an extra slash at the end:
I change this line with:

Now, it works smoothly. 

The evil always comes from details…

Thanks again Francis for your time and your assistance,


Posted at Nginx Forum: https://forum.nginx.org/read.php?2,287709,287727#msg-287727

More information about the nginx mailing list