Weird privilege errors on Ubuntu 20.04

Sergey A. Osokin osa at
Sat Jun 12 01:23:50 UTC 2021

On Fri, Jun 11, 2021 at 07:29:10PM -0400, hgv wrote:
> Out of curiosity, I launched a fresh Ubuntu 20.04 AWS instance. Its file
> system structure matches the one you have. My installation is upgraded
> originally from 16.04 to 18.04 to 20.04. Therefore, I also checked a fresh
> Ubuntu 16.04. Its file system structure matches mine. 
> Hence, it looks like the difference in our file system structures is
> explained by my upgrade path.
> Still not sure if it's relevant to the Nginx issue I'm experiencing, though
> :)

Thanks for the update.

It's more clear now that a file system structure was different when the
issue was registered.  Also, we need to understand how the systemd's systemctl
utility is involved in this process.  And I believe this issue needs to
be reported to Ubuntu Development team, hope that helps to improve the
upgrade process.

Have you tried to reproduce the issue on fresh Ubuntu 20.04 AWS instance?
Is it still reproducible?

Sergey Osokin

More information about the nginx mailing list