unknown directive "js_include" after update to

remdex nginx-forum at forum.nginx.org
Tue Jan 11 05:15:51 UTC 2022


Before updating RPM packages
```
nginx-module-perl-1.20.2-1.el7.ngx.x86_64
nginx-1.20.2-1.el7.ngx.x86_64
nginx-module-xslt-1.20.2-1.el7.ngx.x86_64
nginx-filesystem-1.20.1-9.el7.noarch
nginx-module-njs-1.20.2+0.7.0-1.el7.ngx.x86_64
nginx-module-geoip-1.20.2-1.el7.ngx.x86_64
nginx-module-image-filter-1.20.2-1.el7.ngx.x86_64
```

After updating RPM packages
```
nginx-module-perl-1.20.2-1.el7.ngx.x86_64
nginx-1.20.2-1.el7.ngx.x86_64
nginx-module-xslt-1.20.2-1.el7.ngx.x86_64
nginx-filesystem-1.20.1-9.el7.noarch
nginx-module-geoip-1.20.2-1.el7.ngx.x86_64
nginx-module-njs-1.20.2+0.7.1-1.el7.ngx.x86_64
nginx-module-image-filter-1.20.2-1.el7.ngx.x86_64
```

After yum update is executed `nginx-module-njs` package was updated and now
nginx throws `unknown directive "js_include"` although with the previous
version (nginx-module-njs-1.20.2+0.7.0-1.el7.ngx.x86_64) it worked

Anyone knows why updating to
`nginx-module-njs-1.20.2+0.7.1-1.el7.ngx.x86_64` from
`nginx-module-njs-1.20.2+0.7.0-1.el7.ngx.x86_64` starts throwing that error.
Is this a bug in official repo
(http://nginx.org/packages/centos/$releasever/$basearch/) ?

CentOS Linux release 7.9.2009 (Core)

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,293320,293320#msg-293320



More information about the nginx mailing list