NGINX "--with-zlib=..." linker error

Fabiano Furtado Pessoa Coelho fusca14 at
Tue Mar 29 19:03:19 UTC 2022

Hi Maxim...

I have a ./configure error with two or more parameters on "--with-zlib-opt=...".

I've tried:
  * --with-zlib-opt=-O2 -fPIC
  * --with-zlib-opt="-O2 -fPIC"
  * --with-zlib-opt='-O2 -fPIC'
  * --with-zlib-opt=-O2-fPIC
  * --with-zlib-opt=\-O2\ \-fPIC
... and none of these syntax works.

It works with only one parameter and my solution is to modify the
auto/cc/gcc file.

Thinking about a possible RHEL .spec file bug, I also tried in Arch
Linux, modifying PKGBUILD file and got the same issue.

Thanks again for your help.

On Tue, Mar 29, 2022 at 9:05 AM Maxim Dounin wrote:
> ...
> > Do I need to specify "--with-zlib-opt=-fPIC -O2 -fomit-frame-pointer"
> > because of these ZLIB_OPT default values?
> Yes if you want to match optimizations used by nginx by default
> when building the zlib library.  But that's just optimizations, so
> it's completely optional.

More information about the nginx mailing list