worker process XXXXX exited on signal 11

flash nginx-forum at
Mon Apr 12 05:53:35 MSD 2010

There are several posts on the Russian boards in regards to this issue; however, I have not been able to get anything out of them that would help. (I tried google translate but it is not the best with technical language).

Anyway, I'm getting a lot of these errors in my logs and I have no idea what they are. Here are the worker settings in my conf file:

user nginx;
worker_processes  5;
worker_rlimit_nofile 8192;

error_log   /var/log/nginx/error.log error;
pid        /var/run/;

events {
    worker_connections  4096;
    use epoll;

Maxim posted a script perl script on one of the posts that I thought might shed some light on my problem:

use CGI::Fast;
while (new CGI::Fast) {
print "Content-type: text/html\n\nOk";
warn "".("a" x 503)."\n";

I tried to run this but I'm getting an error when I do:

# /usr/bin/perl
Can't locate in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386                             -linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr                             /lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/                             5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /u                             sr/lib/perl5/5.8.8 .) at /usr/lib/perl5/5.8.8/CGI/ line 22.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/CGI/ line 22.
Compilation failed in require at line 2.
BEGIN failed--compilation aborted at line 2.

I also tried to look in the docs for some clues, but I'm out of ideas.


Posted at Nginx Forum:,73950,73950#msg-73950

More information about the nginx mailing list