Can't seem to enable TLS SNI support (upgraded nginx and openssl)

Ian M. Evans ianevans at
Thu Dec 2 02:13:58 MSK 2010

Did all the steps I thought I was supposed to do to get SNI enabled but
nginx -V still gives me this:

nginx version: nginx/0.8.53
built by gcc 3.2.3 20030502 (Red Hat Linux 3.2.3-59)
TLS SNI support disabled
configure arguments: --with-http_stub_status_module --with-http_ssl_module
--with-debug --with-http_gzip_static_module

I upgraded to openssl 0.9.8p

configured with: ./config --enable-tlsext (even though it's now supposed
to be a default that didn't work either.
make test make install

configured nginx as above, make, make install, started the new binary shut
down the old one.

Any idea why it's still "TLS SNI support disabled"


More information about the nginx mailing list