[newbie] Two configuration issues with PHP5-FPM

Gilles Ganault gilles.ganault at free.fr
Thu Jul 15 15:03:59 MSD 2010


Things are a bit more clear this morning, but I'm still unable to
serve PHP5 scripts through Nginx + PHP5-FPM (works OK with "php-cgi
-b") on Ubuntu 10.04.

Using the "default" file mentioned here...


... and the usual index.php (owned by www-data.www-data) to run "<?php
phpinfo(); ?>", I get two errors:

1. -> "403 Forbidden": 

"directory index of "/var/www/" is forbidden, client:, 
server: localhost, request: "GET / HTTP/1.1", host: """

So, I tried being specific:

2. Empty screen.

Only this in error.log:

2010/07/15 12:50:36 [error] 1146#0: *21 open() "/var/www/favicon.ico"
failed (2: No such file or directory), client:, server:
localhost, request: "GET /favicon.ico HTTP/1.1", host: ""

I get this in /var/log/nginx/localhost.access.log : - - [15/Jul/2010:12:52:15 +0200] "GET /index.php HTTP/1.1"
404 31 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.9 (KHTML, like Gecko) Iron/ Chrome/

(notice error 404)

To check if it could be due to the fact that I use the server's IP
address ( instead of "localhost" to connect to it from a
Windows host, I tried this:

1. vi /etc/nginx/sites-available/default:
server {
    listen   80;
    #ME server_name  localhost;
2. /etc/init.d/nginx restart = Still empty page :-/

Any idea what's wrong with my config?

Thank you for any hint.

More information about the nginx mailing list