permission denied: in nginx

Mauro Stettler mauro.stettler at
Mon Jun 27 16:46:03 MSD 2011

maybe it might help to do strace on the nginx process to see the exact
system call which causes the permission denied. also you have to make
sure that the user under which nginx runs is allowed to access the
device file. for example you could test this by doing sudo -u
nginxuser cat /dev/xxx

On Mon, Jun 27, 2011 at 20:19, pavan.anjaneyulu at
<nginx-forum at> wrote:
> HI
> I am working on nginx, i am developed an small module to read data from
> an external device. when i call module from the browser i am getting an
> error  "Error connecting XXXXX : permission denied"
> i tried to change the permission and owner of the file (chown and
> chmod)but still i got same error. can anyone plz help how to move on
> further
> Regards
> pavan
> Posted at Nginx Forum:,210423,210423#msg-210423
> _______________________________________________
> nginx mailing list
> nginx at

More information about the nginx mailing list